[peruser] seg fault

bert bert at ev6.net
Fri Sep 28 13:35:30 MDT 2007


On 28 Sep 2007, at 20:26, Sean Gabriel Heacock wrote:

> On Fri, 2007-09-28 at 17:30 +0400, Alexey Vlasov wrote:
>> On 5 2007 г. 14:52:56,  wrote about "Re: [peruser] seg fault":
>>> Attached is a patch that fixes it up, let me know if it works for  
>>> you,
>>> all it really does is change some of the data type declarations  
>>> to use
>>> the standard apache types .
>>
>> Yes, your patch helped me greatly.
>
> I can't find the message you're replying to - was it sent to you
> personally?  If the patch fixes problems with FreeBSD and doesn't  
> cause
> any for Linux, I'd like to include it in the new releaese :)

I have attached the patch, but i did post it to this list quite some  
time ago too...
I never tested it on FreeBSD, but i wrote it to cure problems on non  
x86 linux systems, specifically Alpha, Sparc and x86_64, but i think  
those issues turned out to be bugs in gcc 3.x being triggered by  
peruser, as an x86_64 machine with gcc 4.x seems to work just fine  
without this patch.
That said, this patch doesn't have any ill effects on x86 (i run  
peruser on x86 and x86_64 systems side by side) so it should be  
fairly safe. I run them both on gentoo, using a custom ebuild (build  
script) that includes peruser and a couple of the patches that have  
been posted to this list lately.

>> But now I see in the log the following:
>> [Fri Sep 28 16:21:27 2007] [crit] (13)Permission denied:  
>> mod_rewrite: could
>> not init rewrite log lock in child
>
> Yeah, this has always been a problem.  I ran into it in the very early
> days, but couldn't figure out a solution so I just commented out
> RewriteLog.  That'll get you running but then you don't have that log.
> I'll try and revisit that issue over the weekend.
>
> -- 
> Sean Gabriel Heacock
> Telana Internet Services
> http://www.telana.com/
>
> _______________________________________________
> Peruser mailing list
> Peruser at telana.com
> http://www.telana.com/mailman/listinfo/peruser

-------------- next part --------------
A non-text attachment was scrubbed...
Name: peruser-nonx86.patch
Type: application/octet-stream
Size: 2769 bytes
Desc: not available
Url : http://www.telana.com/pipermail/peruser/attachments/20070928/4371f14b/attachment.obj 


More information about the Peruser mailing list