[peruser] Multiple simultaneous connections issues

Marc Knaup marc at icefinch.net
Sun Apr 2 14:41:23 MDT 2006


Same problem here:
I open a first connection to server on port 80 without sending anything. I
start a request using a secondary connection. This request is served as soon
as I close the first connection.


-- Marc



----- Original Message ----- 
From: <bert at ev6.net>
To: <peruser at telana.com>
Sent: Sunday, April 02, 2006 9:10 PM
Subject: [peruser] Multiple simultaneous connections issues


> Hi,
>
> I currently have a few systems running mpm-peruser on linux, on which i
> have encountered a rather strange issue:
>
> If i telnet to port 80 of the webserver with 2 seperate instances of
> telnet, and issue an HTTP request on the second copy (leaving the first
> connected but idle) the request won't be served until the first connection
> has finished (by disconnecting or issuing a request itself). When this
> happens, only the first connection is showing up in netstat on the server
> (although the clients believe they're both connected)
>
> By leaving a connection sitting idle to the apache server, you could
> effectively denial of service the site.
>
> This issue manifests itself with Apache 2.0.55 and mpm-peruser 0.2.0 on
> gentoo linux (custom compiled, not using gentoo ebuilds) and earlier
> versions.
>
> The systems "mastermind.ev6.net" and "tardis.ev6.net" are two of my test
> systems which are afflicted by this bug, incase anyone wishes to see it
> for themselves.
>
> _______________________________________________
> Peruser mailing list
> Peruser at telana.com
> http://www.telana.com/mailman/listinfo/peruser 




More information about the Peruser mailing list